Can I use the apple magic trackpad on a Power PC G5 running OSX 5.4.1

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    Unfortunate no the trackpad minimum OS is 10.6.4, "snow leopard" with an intel processor.

    Was this useful? Answer 1

    5 of 6 people found this useful

  • No, Mac OS X v10.6.4 or later

    Was this useful? Answer 2

    4 of 4 people found this useful

Related Questions