why does keyboard say minimum requirements 10.5.8.

why does keyboard say minimum requirements 10.5.8. my system is mac os x 10.4.11. will it work properly

Apple Wireless Keyboard - English

Back To Product

Follow this Question

1 Answer from the Community

  • if you read in some forum threads, you will see, that some also use this keyboard on a os x 10.4.x..but no guarantee that it will really work

    Was this useful? Answer 1

    1 of 3 people found this useful

Related Questions