Will this work at all with OSX 10.4? i.e. are there just specific minor functions that only work with 10.5, or is 10.5 an absolute necessity?

Back To Product

Follow this Question

1 Answer from the Community

  • the page of system requirements on apple's page says that it only works with 10.5 leopard, not tiger.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions