Is the MM compatible with my Macbook pro, I'm running Mac OS X 10.5.2?

Apple Magic Mouse

Back To Product

Follow this Question

3 Answers from the Community

  • Answer

    Short answer: no.

    Longer answer: You need to update to at least 10.5.8 (which can be done via Software Update for free, seeing as you have 10.5.2).

    "Minimum Requirements

    A Bluetooth-enabled Macintosh computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0* or Mac OS X v10.6.1 or later with Wireless Mouse Software Update 1.0

    *Momentum scrolling supported only on Mac OS X v10.6 Snow Leopard"

    Was this useful? Answer 1

    1 of 1 people found this useful

  • You will need to upgrade to 10.5.8 and download the magic mouse driver update from apple's support page, provided that your mac doesn't grab it from system update automatically, and then you can use the magic mouse

    Was this useful? Answer 2

    1 of 1 people found this useful

  • No, but if you do a software update (click on the apple and select software update) then you will update for free to 10.5.8 or something higher for (can't remember). Then just download the magic mouse software off the apple website and you're set to go!

    Was this useful? Answer 3

    0 of 0 people found this useful

Related Questions