I have 10.4.11. Can I buy the "MAC BOX SET" & install to make Magic Mouse work?

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Yes, you can do that. The Mac Box Set is really Mac OS X Snow Leopard, iLife, and iWork.

    NOTE: Be sure your current computer is capable of running Mac OS X Snow Leopard! It will NOT work on PowerPC computers: Only Intel based Macs. Check the minimum requirements on the Mac Box Set page.

    Was this useful? Answer 1

    1 of 1 people found this useful

  • It depends on the computer you own. Be certain to meet the minimum requirements...

    • A Bluetooth-enabled Macintosh computer
    • Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0 or
    Mac OS X v10.6.1 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 2

    1 of 2 people found this useful

Related Questions