Does the Magic Mouse work with PowerPC (G5) Macs?

Back To Product

Follow this Question

4 Answers from the Community

  • Best Answer:

    The Magic Mouse needs OSX 10.5.8 Minimum - so as long as your PPC Mac is on 10.5.8, you should be fine.

    Was this useful? Answer 1

    22 of 28 people found this useful

  • Magic Mouse requires:
    1) Mac OS X v10.5.8 or later (with Wireless Mouse Software Update 1.0)
    AND
    2) A Bluetooth-enabled Mac.

    As long as you have both, you can use the Magic Mouse.

    Was this useful? Answer 2

    13 of 17 people found this useful

  • The Magic Mouse works with my Sep. 2005 Mac mini, one of the last with the PowerPC processor, running OS 10.4.11. However, only basic features such as left-click and right-click are supported. MIddle-click, scrolling, swiping, battery level, and anything else are not supported. Taking this into account, the Apple Mighty Mouse would be a much better choice for any similar system.

    Was this useful? Answer 3

    6 of 8 people found this useful

  • You need to have Leopard and bluetooth. I don't think my PowerPC has bluetooth, but you get buy bluetooth USB stick for about $10 (I have one). So iI'll be doing that.

    Was this useful? Answer 4

    9 of 15 people found this useful

Related Questions