Does it support of Windows Vista or 7 operating system?

Apple Magic Mouse

Back To Product

Follow this Question

2 Answers from the Community

  • It only works with Macs running Mac OS X version 10.5.8 or later.

    Was this useful? Answer 1

    3 of 7 people found this useful

  • No.

    "Minimum Requirements
    A Bluetooth-enabled Macintosh computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0"

    Was this useful? Answer 2

    2 of 10 people found this useful

Related Questions