can i use it with my late 2009 macbook-pro

Apple Magic Mouse

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Definitely - the minimum system requirements listed are:

    -A Bluetooth-enabled Macintosh computer

    -Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0* or Mac OS X v10.6.1 or later with Wireless Mouse Software Update 1.0

    As long as you've run all your software updates it'll have no problems.

    Was this useful? Answer 1

    3 of 3 people found this useful

  • Yes, You can.

    Was this useful? Answer 2

    2 of 2 people found this useful

Related Questions