Back To Product

Follow this Question

1 Answer from the Community

  • No.
    Minimum System Requirements

    * Mac computer with available USB 1.1 or USB 2.0 port
    * Mac OS X v10.4.1 or later
    * Keyboard software update

    Was this useful? Answer 1

    0 of 1 people found this useful

Related Questions