Why won't this keyboard model work with Panther? I bought this and I have the Panther OS which I'm going to install. I have defected from Windows.

Apple MB110LL/A

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Rocky- Unfortunately the current Genuine Apple Keyboards tend to be incompatible with the older Mac OS and older (late model) Macintosh computers. The why part I believe to be related to the computer/keyboard firmware then the Mac OS of which must be able to "see" the keyboard.

    Was this useful? Answer 1

    3 of 5 people found this useful

  • If you check the spec on the web page, it the minimum requirements are 10.4 which is Tiger, So why not grab a copy and instal that. Unfortunatly I dont think there is an update for it

    Was this useful? Answer 2

    1 of 3 people found this useful

Related Questions