The instructions in the package say I need v10.7 or later. Everything else says 10.6.8. Which is it?

Back To Product

Follow this Question

1 Answer from the Community

  • It's 10.6.8. Not everything Apple makes is compatible with Snow Leopard but you will probably have better luck with Lion. Download the Mac App Store from Apple's website and make a purchase of Lion for US$29.99. The reason I recommend this is because the new wireless keyboard has up-to-date F3 and F4 keys (F3 for Mission Control and F4 for Launchpad).

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions