Can i use this keyboard for an eMac OS X 10.3.9??

Back To Product

Follow this Question

1 Answer from the Community

  • Probably not as the system requirements state it can only be used on 10.4 upwards.

    Was this useful? Answer 1

    0 of 1 people found this useful

Related Questions