I have a Mac OS X Lion 10.7.4. is this compatible with the HP photosmart 5520 e-all in one printer???

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Yes

    Was this useful? Answer 1

    1 of 1 people found this useful

  • It says in compatibility section OS x 10.6 or higher so would that not be lower then OS x lion 10..7.4

    Was this useful? Answer 2

    0 of 1 people found this useful

Related Questions