does this mic work with imac osx version 10.8.2

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes, it will work with OSX 10.82. In the description of the product there is a sub-heading titled "Compatibility". There it says "Mac OS X v10.6.4 or later", the all later referring to all models after 10.6.4.

    Was this useful? Answer 1

    8 of 9 people found this useful

Related Questions