Will OS X Mavericks work with Macbook Snow leopard version 10.6.8 ?

I'm really want to know will it work on OS X 10.6.8 ? Will it cost any damages to Macbook 2006 with 4 GB of RAM ?Because I have never seen the review for this version so I just hesitate to download this OS X Mavericks.

Mac

Follow this Question

1 Answer from the Community

  • Best Answer:

    There's two (2) considerations when 'upgrading' your OS; Which version of OS X am I currently running, and which model Mac do I have?

    Firstly, in general you can upgrade from OS X 10.6.8. Secondly, your Mac needs certain hardware for particular OS X versions to operate, which in your case, your Macbook seems to be too old to support OS X Mavericks, so installing Mavericks doesn't appear to be an option for you.
    You can find further information on Mac models that support Mavericks here:
    http: // www . apple . com/au/osx/specs/ (take out the spaces...)

    If anyone is unsure as to which year model etc. their Mac is, you can search by keywords here:
    http: // support . apple . com/specs (take out the spaces..). The best way I found to search is enter your processor's details as found in the 'About This Mac' window, and enter them inside quotation marks ( "processor's details here" ), e.g. "2.4 GHz Intel Core 2 Duo".

    Hope this helps!

    Was this useful? Answer 1

    11 of 13 people found this useful

Similar Questions

See more Similar Questions