Need at least 10.7.4 on my MAC to run I-cloud. I have 10.5.8. Can I update to that?

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes!

    First, call apple support. They will provide you with a link that you can purchase 10.6. Then buy 10.7 from the mac app store. while you are on the phone, ask if you can buy 10.7 directly.


    Hope this helped!

    Chase

    Was this useful? Answer 1

    15 of 19 people found this useful

Similar Questions

See more Similar Questions