MACBOOK 2.1 UPGRADE & 10.6.8 required

Hi, I have an old Macbook 2,1. I've got the new iPhone 5c and it needs 10.6.8... but if i buy Snow Leopard will it even work?? I don't want to waste my time or money on something that won't work! :(

Really appreciate any advice anyone....
Thanks

Follow this Question

No Answers have been submitted

Be the first to answer this question.  Answer now

Similar Questions

See more Similar Questions