Can I upgrade my G4 to Leopard or Snow Leopard?

Follow this Question

1 Answer from the Community

  • Answer

    Im writing this on my Ibook G4 now, and yes you can install Leopard, or Mac OS X 10.5 on it, but the core processor can handle Snow Leopard or Mac OS X 10.6, its just not compatible, you have to have an intel processor, but unfortunately the IBook G4 isn't compatible for an intel processor either, so to put it mildly your stuck with 10.5 or below.

    Was this useful? Answer 1

    2 of 2 people found this useful

Similar Questions

See more Similar Questions