I want to replace my old 1st Gen Airport Express. I happen to also need a new backup/hard drive. Will TC be compatible an older Macbook Pro 2008?

  • Asked by Alison P from Long Island City
  • 09-Feb-2013
QA Apple Time Capsule

QA Apple Time Capsule

Product No Longer Available

1 Answer from the Community

  • It all depends on the version of OS X you are using on your MacBook Pro . If it is leopard or later you should be fine. And I am guessing you do use leopard or later .

    • Answered by Kerolos A from Halifax
    • 30-Mar-2013