Does this work with Snow Leopard?

  • Asked by Alyssa F from Huntingdon Valley
  • 05-Mar-2010
Intego Internet Security Barrier X6

Intego Internet Security Barrier X6

Product No Longer Available

1 Answer from the Community

  • Answer

    See Intego's website. It says, "For Mac OS X 10.5 and 10.6
    (Leopard and Snow Leopard)"

    So, yup!

    • Answered by Matthew F from Roy
    • 08-Mar-2010