Do I need any specific IOS on my ipod/ipad to install the software?

  • Asked by Javier M from Katy
  • 25-Nov-2011
Silverlit Interactive Bluetooth Remote Control Enzo Ferrari Car

Silverlit Interactive Bluetooth Remote Control Enzo Ferrari Car

Product No Longer Available

1 Answer from the Community

  • This app is for iOS 4 and above.

    • Answered by Punit D from Kolkata
    • 03-Mar-2013