Snow Leopard compatible with Adobe Creative Suite?

I have Adobe Creative Suite 5 running on Mac OS 10.5.8. I want to upgrade at least to Snow Leopard (but not much further since I have only 1 GB Ram). Is Snow Leopard 10.6.8 compatible with Adobe Creative Suite 5?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    CS5 should work just fine on Snow Leopard. However, it would still make sense to upgrade your RAM to at least 2GB, more if you can. Creative Suite applications tend to be resource hungry and more RAM will help everything to run more smoothly.

    Was this useful? Answer 1

    5 of 5 people found this useful

  • Yes! I was using CS5 with Snow Leopard. Now using it with Mountain Lion.

    Was this useful? Answer 2

    2 of 2 people found this useful

Related Questions