I am running 10.5.8 on a mac mini. looking to run turbo tax 2012 - says it won't run with this OS, yet initially said it needed 10.5 to run. help??

Is there something else I need to do to get turbo tax to work with this OS? I don't understand why it won't run.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • From the turbo tax website

    Requirements for Turbo Tax 2012 are
    Mac OS X v10.6.8 or later
    Mac OS X v10.7.5 or later
    Mac OS X v10.8.0 or later

    Your only option appears to be to upgrade your OS, sorry

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions