In 'Overview': Parallels 9 is compatible with OS X 10.9 thru' to OS X 10.6.4; 'System Requirement' is OS X 10. 8.4 or later. Which is correct?

Parallels Desktop 9 for Mac - Education Edition

Back To Product

Follow this Question

1 Answer from the Community

  • It will run on any OSX version from 10.6.8

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions