What version of Quicken do I need for 10.8.2

Was using 2005 and now it is not compatible with my new iMac

Mac

Follow this Question