do I need snow leopard to sync my iphone 5 to my macbook os x which I bought in 2009?

It won't let me sync my new iphone without the 10.6 version software.

Mac

Follow this Question

2 Answers from the Community

  • Best Answer:

    Do an internet search for "apple.com iphone specs".

    The iPhone 5 requires the following to sync iTunes with Mac:
    - Mac OS X 10.6.8 or later (Mac OS X 10.6.8 is the last update of Snow Leopard)
    - iTunes 10.7 or later

    Was this useful? Answer 1

    17 of 28 people found this useful

  • Yes. I had to install it on my MacBook I bought in '09

    Was this useful? Answer 2

    5 of 5 people found this useful

Similar Questions

See more Similar Questions