Snow Leopard before Mountain Lion?

I have a Mac from 2009 with a 2.66 Ghz Intel Core 2 Duo processor, version 10.5.8. Do I need to buy Snow Leopard or can I just by Mountain Lion?

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    Personally, don't bother with 10.8- Snow Leopard has been tagged as a very and reliable stable operating system for many into photography, music and high processor-demanding applications.

    Your system is plenty for Snow Leopard but might take a hit on Mountain Lion. I/m running an early 2010 MBP and experienced issues immediately with ML, but none with SL

    Hope this helps

    Was this useful? Answer 1

    60 of 64 people found this useful

  • The only way to buy Mountain Lion is from the Mac App Store, which is part of Snow Leopard and later version of OS X. That's why you need to buy Snow Leopard before you can buy Mountain Lion.

    Was this useful? Answer 2

    51 of 52 people found this useful

Related Questions