Will this work with a Mac Mini ?

i want to use the Apogee ensemble with Logic 9 and a Mac Mini.

  • Asked by Gary H from Mount Morris
  • 2-Feb-2010
Apogee Ensemble Audio Interface

Apogee Ensemble Audio Interface

Product No Longer Available

1 Answer from the Community

  • Answer

    Yes as long as it's running 10.4 or above
    Logic 7 or above.
    512mb ram 1gb recommended by Apogee.

    • Answered by Sergio R from North Hollywood
    • 5-Feb-2010