I want to buy Time Capsule for a Mac PowerBook G4 (OS X version 10.4.11). Will it work? If not, what needs upgrading?

  • Asked by Sharon F from Princeton
  • 19-Oct-2009
QA Apple Time Capsule

QA Apple Time Capsule

Product No Longer Available

3 Answers from the Community

  • Best Answer:

    Depends on what features you are talking about. It will do everything as advertised except for backup your mac as the time machine feature was not implemented until Leopard (10.5). The good news is that you can install Leopard on a G4 PowerBook.

    • Answered by Stuart M from Warren
    • 20-Oct-2009
  • You need 10.5 (Leopard) installed. The required software (Time Machine) is in the OS.

    • Answered by Dru J from Kennesaw
    • 20-Oct-2009
  • You could use it as a wireless access point but you would need to upgrade to OS X 10.5 (Leopard) to back up using Time Machine.

    • Answered by Chris T from Naperville
    • 20-Oct-2009