Can I run PSE11 on older MacBook Pro?

I recently upgraded to a newer camera model and was running PSE6 on my mid-2008 MacBookPro. I know that I have to upgrade to 11 to process RAW files from the new camera. However, I already have issues with 6.0 crashing on the system I have. I'm worried that by the time I upgrade to Snow Leopard and then Mountain Lion, and add in the PSE 11, the machine won't be able to handle it. Any advice?

Adobe Photoshop Elements 11

Adobe Photoshop Elements 11

Product No Longer Available

No Answers have been submitted