magic trackpad

Hi, could anyone advise me:

I've just bought the Magic Trackpad. According to the Quick Start guide, it advised the user to update the Mac OS X to version 10.6.4. I do not know whether it is the right upgrade to buy Mac OS X 10.6 Snow Leopard.

Thank you.

Back To Product

Follow this Question

2 Answers from the Community

  • Click the  logo in top Left of screen, Click "About this Mac" Under MAC OS X it will say "Version 10.5.8 or 10.6.* if you have 10.5.* you need to upgrade to Snow Leopard which is 10.6.0
    10.5.* is known as "Leopard"
    If you have a Intel Dual Core processor or Higher, you should Upgrade to Lion 10.7
    But I think in doing so you'll need to be at 10.6.8 in order to do so... I'm not a 100% sure if this is true… but I think it is. (You download Lion from the Mac App Store) icon is installed to your DOCK once you reach 10.6.7 i believe. maybe 10.6.6

    good luck!

    Was this useful? Answer 1

    2 of 5 people found this useful

  • If you are running 10.5 (Leopard) then the £25 single user disc is fine. If not Apple suggests you buying the Mac Box Set. Then go to Software Update from the Apple Menu (top left corner) and update the system if there are any new updates available.

    Was this useful? Answer 2

    1 of 4 people found this useful

Related Questions