is snow leopard compatible with my current software running on 10.5.8?

I need to be able to run Quicken 2007 in particular.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    If you have a Intel CPU, yes, but if you have a Power PC CPU, no.

    Was this useful? Answer 1

    5 of 8 people found this useful

Related Questions