I have mac os x v10.4.11 and want to buy a magic mouse but it says requirements are mac os x v10.5.8 so what do i need to buy to work it?

do i need to buy box set with snow leopard in?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    If you have a Mac with a PowerPC processor (like a G5), you'll need to buy Mac OS X 10.5 Leopard. If you have an Intel Mac, you can use Leopard, but Mac OS X 10.6 Snow Leopard would be a much better buy. If you are unsure of which you have, click the Apple Menu and select About This Mac. Your processor and memory specifications will be listed there. Remember to run Software Update after installing either one to ensure that you have all the latest updates and back up your data before upgrading.

    Was this useful? Answer 1

    36 of 43 people found this useful

Related Questions