I have a powerbook g4 can i use snow leopard on it?

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    No, You MUST have an Intel Mac!

    Was this useful? Answer 1

    13 of 14 people found this useful

  • Unfortunately, no. Snow Leopard is only compatible with Intel multicore processors, and will not install on G5 or earlier processors like yours. Sorry!

    Was this useful? Answer 2

    13 of 14 people found this useful

Related Questions