can it work for an older powerbook g4

I'd like to buy either or both a magic mouse and a magic trackpad. I have a new I mac 27", an older imac 21", an older powerbook g4 and also an ibook. I'd like to find some new gear that will work for all of the above. is this possible and if so what OS and Bluetooth OS do I need on each of them.

Thanks immensely in advance.

jonny apple seed

Magic Trackpad

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    No, it will not work because G4 does not support Snow Leopard, which is needed for the operation of Magic Trackpad.

    Was this useful? Answer 1

    3 of 4 people found this useful

Related Questions