will this work with 10.3 ?

Back To Product

Follow this Question

14 Answers from the Community

  • Best Answer:

    No you need Mac OS X v10.5.8 or higher with bluetooth.

    Was this useful? Answer 1

    5 of 6 people found this useful

  • According to the minimum requirements, the Magic Mouse requires Mac OS X v10.5.8 or later. So the answer is no I'm afraid.

    Was this useful? Answer 2

    3 of 3 people found this useful

  • No, the earliest-supported version of the Mac OS is Leopard, 10.5.8.

    Was this useful? Answer 3

    2 of 3 people found this useful

  • No. "Mac OS X v10.5.8 or later" is required.

    Was this useful? Answer 4

    2 of 3 people found this useful

  • If you're still using 10.3 you've got bigger problems than the Magic Mouse not working. To answer your question: no the Magic Mouse requires at least 10.5.8 so just go to the Apple Store or go online and buy Snow leopard, or possibly a new Mac if it's that old.

    Was this useful? Answer 5

    1 of 2 people found this useful

  • Not according to the specs:

    Minimum Requirements
    A Bluetooth-enabled Macintosh computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 6

    1 of 2 people found this useful

  • According to the specs NO. requires Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 7

    1 of 2 people found this useful

  • No, the minimum requirements are "Mac OS X v10.5.8 or later".

    Was this useful? Answer 8

    1 of 2 people found this useful

  • The minimum requirements state:

    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 9

    1 of 2 people found this useful

  • All signs point to no.

    Was this useful? Answer 10

    1 of 2 people found this useful

  • Minimum Requirements
    - Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 11

    1 of 2 people found this useful

  • There is no reason you should still have 10.3. no you need 10.5.8 atleast

    Was this useful? Answer 12

    1 of 2 people found this useful

  • Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0

    So no.

    Was this useful? Answer 13

    1 of 2 people found this useful

  • It should work in 10.3 as a basic mouse, if that's what you're asking.

    Was this useful? Answer 14

    1 of 3 people found this useful

Related Questions