will magic mouse work with intel imac (early 2006) running snow leopard ?

imac has been upgraded to 2GB RAM and is running Snow Leopard

Back To Product

Follow this Question

3 Answers from the Community

  • Answer

    The Magic Mouse System Requirements are:

    Bluetooth-enabled Mac computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0
    Existing keyboard and mouse for setup

    Snow Leopard falls under the "or later" category, and the Wireless Mouse Software Update 1.0 is included with the mouse.
    So long as you have bluetooth on your iMac, it should work fine.

    Enjoy!

    Was this useful? Answer 1

    4 of 4 people found this useful

  • Yes as long as it has bluetooth which I believe all the computers ince early 2006 have with the exception of some Mac Pros (traditional CPU and monitor setups).

    Was this useful? Answer 2

    3 of 3 people found this useful

  • yes. it will run on any snow leopard or regular leopard version 1.5.8

    Was this useful? Answer 3

    2 of 2 people found this useful

Related Questions