will it work with 10.5.7

Back To Product

Follow this Question

3 Answers from the Community

  • Answer

    No, It works with 10.5.8 OR LATER.

    Was this useful? Answer 1

    3 of 3 people found this useful

  • No. The minimum requirement is 10.5.8 or higher.

    Was this useful? Answer 2

    3 of 3 people found this useful

  • No, you need at least 10.5.8.

    Was this useful? Answer 3

    3 of 3 people found this useful

Related Questions