Purchased Magic Mouse-love sleek design, but can't double click on desktop icon to open -I have to click on the icon then OPEN from drop down menu. ??

Apple Magic Mouse

Back To Product

Follow this Question

1 Answer from the Community

  • Go to system preferences, mouse and check your setting for double-click. You probably have it set at maximum or 100%. Reduce your setting to about three bars from the right. Your icon should now open when you double click.

    Was this useful? Answer 1

    7 of 14 people found this useful

Related Questions