Does the mouse work on the older versions of the iMac?

Apple Magic Mouse

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    It depends on two things:

    1) Does your iMac support Bluetooth? Since the mouse is wireless, it requires Bluetooth to interact with your iMac. Bluetooth support has been standard on iMacs since late 2004 and available on some models as early as 2003 (17 inch G4).

    2) Which version of Mac OS X are you currently running? If you have Leopard (10.5, released Oct. 2007) or Snow Leopard (10.6) then you will be able to use the complete functionality of the mouse. Using 10.4 or older will lead to unpredictable results. Point and click functionality will likely work although more advanced features including scrolling, and web backwards/forwards will likely not work.

    Was this useful? Answer 1

    9 of 9 people found this useful

  • Yup, i have the snow leopard. Thank you very much :)

    Was this useful? Answer 2

    1 of 1 people found this useful

Related Questions