Do I need to Download Software for Magic Mouse to wrk properly

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Minimum RequirementsA Bluetooth-enabled Macintosh computer
    Mac OS X v10.5.8 or later with Wireless Mouse Software Update 1.0* or Mac OS X v10.6.1 or later with Wireless Mouse Software Update 1.0

    Was this useful? Answer 1

    5 of 9 people found this useful

Related Questions