Will current keyboard work with OS 10.5.8?

According to specs, minimum OS is 10.6.8.

Back To Product

Follow this Question

2 Answers from the Community

  • Best Answer:

    The Function keys will not all work properly on 10.5.8, all the other keys will be fine. The previous model MB110LL/A would work with all the Function keys on Leopard or Snow Leopard.

    Was this useful? Answer 1

    24 of 25 people found this useful

  • Yes

    Was this useful? Answer 2

    3 of 5 people found this useful

Related Questions